Viewing 1 to 4 (4 Total)
Random access bit

info@boldmss.com

Total Posts:
Joined: May 21, 2014

Hello!

I'm trying to stream using ffmpeg to a STB, with no success. On iOS and Android it works without any trouble. From the STB software support i got this answer:


4.1.5.1 Random_access_indicator For H.264/AVC Bitstreams, the following applies: Encoding: The random_access_indicator bit shall be set whenever an H.264/AVC RAP occurs in video streams (see H.264/AVC RAP definition in Clauses 3.1 and 5.5.5). Decoding: The random_access_indicator bit may be ignored by the IRD. It can be beneficially utilized together with the elementary_stream_priority indicator to identify RAP.

3.1 H.264/AVC RAP: access unit with AU delimiter in an H.264/AVC Bitstream at which an IRD can begin decoding video successfully. This access unit shall include exactly one Sequence Parameter Set (that is active) with VUI and the Picture Parameter Set that is required for decoding the associated picture. The SPS shall also precede any SEI NAL units in this access unit. This access unit must contain an IDR picture or an I picture


I cant't figure out how to set that bit up! With working streams my STB shows:

dec[2][base] :: set_video_track() : -1 -> 0 [H264]

dec[2][base] :: set_audio_track() : -1 -> 0 [AAC] [eng]


But with my stream

dec[1][base] :: set_video_track() : -1 -> -1 []

dec[1][base] :: set_audio_track() : -1 -> 0 [AAC] [spa]


My Ffmpeg command

ffmpeg -nostdin -loglevel info -ss 10 -hwaccel_device 0 -hwaccel cuvid -c:v h264_cuvid -deint 2 -y -re -i udp://X.X.X.X:XXXX?pkt_size=1316\&buffer_size=409600\&fifo_size=1000000\&overrun_nonfatal=1 -movflags isml+frag_keyframe -f ismv -threads 0 -c:a libfdk_aac -ac 2 -b:a 64k -map 0:v -filter:v:0 scale_npp=w=1024:h=576 -c:v:0 h264_nvenc -preset llhq -g 150 -keyint_min 150 -forced-idr 1 -aud 1 -strict_gop 1 -bf 2 -flags:v +global_header -pcr_period 5 -b:v:0 1200k -bsf:v h264_mp4toannexb -map 0:v -filter:v:1 scale_npp=w=1920:h=1080 -c:v:1 h264_nvenc -preset llhq -g 150 -keyint_min 150 -forced-idr 1 -aud 1 -strict_gop 1 -bf 2 -flags:v +global_header -pcr_period 5 -b:v:1 2000k -bsf:v h264_mp4toannexb -map 0:v -filter:v:2 scale_npp=w=640:h=368 -c:v:2 h264_nvenc -preset llhq -g 150 -keyint_min 150 -forced-idr 1 -aud 1 -strict_gop 1 -bf 2 -flags:v +global_header -pcr_period 5 -b:v:2 1200k -bsf:v h264_mp4toannexb -map 0:a:0http://XXX/X/X


I'm using last version of ffmpeg & nvidia & mp4split.


Any ideas?

Tags: mp4split, ffmpeg, nvidia
Posted on August 31, 2017 at 9:42 PM

Dirk

Total Posts:
Joined: June 23, 2010

Re: Random access bit

Hi,

I am very sorry, but I do not hat the FFmpeg knowledge to help you here.

Perhaps you could post the FFmpeg mailing lists or trackers?

Best

Posted on September 04, 2017 at 8:53 AM

info@boldmss.com

Total Posts:
Joined: May 21, 2014

Re: Random access bit

Hello!

I discarded ffmpeg problems because with the same command I created an ismv file and on my STB works like charm!
The only difference is that on my ffmpeg command I don't use "-f ismv", flag witch can't be erased for http streaming.

With a live input I can't make it work!
This is my delivery command:



mp4split -o /content/Teledoce_HD/Teledoce_HD.isml --hls.minimum_fragment_length=6 --time_shift=0 --archive_segment_length=60 --iss.minimum_fragment_length=4 --hls.client_manifest_version=4 --dvr_window_length=600


Thanks!

Posted on September 07, 2017 at 10:41 PM

will@unified-streaming.com

will@unified-streaming.com
Total Posts:
Joined: August 04, 2015

Re: Random access bit

Hi there, we do not provide ffmpeg support or troubleshooting I'm afraid. You should contact ffmpeg or use their forums and support services.

Kind regards,

Will.

Posted on September 08, 2017 at 1:06 PM